commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Apache's Maven repository missing commons-io, most versions
Date Thu, 30 Mar 2017 00:24:15 GMT
On 30 March 2017 at 01:20, sebb <sebbaz@gmail.com> wrote:
> Try
>
> http://repo.maven.org/maven2/commons-io/commons-io/
>
> IO used to have a different group id.

I mean, still has a different gid.

The entry under
https://repo.maven.apache.org/maven2/org/apache/commons/commons-io/1.3.2

is a relocation pom. Probably that version was accidentally released
with the wrong gid.

> On 30 March 2017 at 00:31, Russell Bateman <russ@windofkeltia.com> wrote:
>> As I attempt to build, I find
>>
>> https://repo.maven.apache.org/maven2/org/apache/commons/commons-io/2.5/commons-io-2.5.jar
>>
>> to yield a 404. When I go look there, only 1.3.2 exists and even that,
>> though there are JARs galore, has a /pom.xml/ that basically refers Maven to
>> Maven Central. Must I then put something into my /pom.xml/ that deters Maven
>> from ever looking for anything in /repo.maven.apache.org/? It seems strange
>> that Apache would offer a Maven repository that's missing an important
>> library (for me, at least). Until now, I haven't had this experience with
>> other Apache Commons libraries.
>>
>> Please advise, thank you!
>>
>> Russ

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message