commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benedikt Ritter <brit...@apache.org>
Subject Re: [dbutils] Issue when using more than 1 parameter in query
Date Mon, 16 Nov 2015 19:03:19 GMT
Hello Amol,

2015-11-10 21:03 GMT+01:00 Amol Kulkarni <amolkulkar@gmail.com>:

> Hi,
>
> I am getting a ORA-00942: table or view does not exist when I query using
> dbutils api with 2 parameters. My enviroment si WAS 8.5.5 and oracle db 11g
>
> I am using dbutils1.6 to make db calls. The problem occurs if I send two
> query parameters like SELECT * FROM  DIGITAL_CERTIFICATE_CACHE WHERE
> CERT_SUBJECT_NAME=? AND CERT_STATUS=? Parameters: [70-B3-D5-1F-30-4E-DF-20,
> I] . If I send only one SELECT * FROM  DIGITAL_CERTIFICATE_CACHE WHERE
> CERT_SUBJECT_NAME=? Parameters: [70-B3-D5-1F-30-4E-DF-20] then query
> returns  and application is working. My dbutils code is as follows
>
>
>
>    QueryRunner run = new QueryRunner(${DataSource});
>             // getting Query from propertues file to fetchBySubject
>             String sqlquery = PropertyFileUtil
>                     .getPropertyValue("fetchbysubject.sql");
> [fetchbysubject.sql = SELECT * FROM DIGITAL_CERTIFICATE_CACHE WHERE
> CERT_SUBJECT_NAME=? AND CERT_STATUS=?]
>             // preparing instance for Custom ResultSetHandler to process
>             // ResultSet
>             ResultSetHandler<List<DigitalCertificateCache>> handler = new
> DPIServicesDAOResultSetHandler();
>             results = run.query(sqlquery, handler, new Object[] {
> subjectname,
>                     "I" });
>
>
>
> Can somebody please point the problem.
>

Does it work, when you run the query via the command line?

Regards,
Benedikt


-- 
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message