commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benedikt Ritter <brit...@apache.org>
Subject Re: [beanutils] Getting issue with Bean Utils v1.9.2.
Date Wed, 24 Jun 2015 05:42:48 GMT
Hello Ramesh,

can you please file a bug at https://issues.apache.org/jira/browse/BEANUTILS
? Would be good if you could provide a JUnit test reproducing the issue
that works with 1.6 but fails with 1.9.2.

Thank you!
Benedikt

2015-06-23 14:38 GMT+02:00 Gopi Ramesh <gopi_ramesh@hotmail.com>:

> Hi,
> In our application, we upgraded the BeanUtils jar from 1.6 version to
> 1.9.2.After upgrading the jar, we are facing issues while setting the bean
> properties for two dimensional or multi dimensional arrays.The same code is
> used to work fine with 1.6 BeanUtils version.
> The error is shown below:java.lang.NullPointerException at
> org.apache.commons.beanutils.BeanUtilsBean.setProperty(BeanUtilsBean.java:925)
>      at
> org.apache.commons.beanutils.BeanUtilsBean.populate(BeanUtilsBean.java:821)
> at org.apache.commons.beanutils.BeanUtils.populate(BeanUtils.java:431)  at
> org.apache.struts.util.RequestUtils.populate(RequestUtils.java:1252) at
> org.apache.struts.action.RequestProcessor.processPopulate(RequestProcessor.java:821)
> Truncated. see log file for complete stacktrace
> Please let me know if is there any solution for the issue.
> Note: We are using BeanUtils with JDK 1.8.0_45.
> Thanks,Ramesh




-- 
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message