commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: [configuration] Adding CData to xml property
Date Tue, 06 Jan 2015 17:40:07 GMT


On 06.01.2015 17:55, jeevi tesh wrote:
> Hi,
>
> Need to add CDATA into XML Property element, but special character are
> getting added. Here is my code. Please give your thoughts on the same.
>
> Here is the code.
>
> String cDataTagStart="\\<![CDATA[";
>
> String cDataTagEnd="]]\\>";
>
> credentialsURL =cDataTagStart+credentialsURL+cDataTagEnd;
>
> xmlContentOfMetaData = CredentialProvider.*getInstance*();
>
> xmlContentOfMetaData.addProperty("Resource(-1).ResourceName", resourceName);
>
> xmlContentOfMetaData.addProperty("Resource.ResourceURL", credentialsURL);
>
>
>
> But Special characters are getting added
>
> ResourceName>TESTRESOURCENAME</ResourceName>
>
> <ResourceURL>\&lt;![CDATA[TESTCredentialsURLS2]]\&gt;</ResourceURL>
>

XMLConfiguration ensures that for newly added or updated properties 
valid XML is generated. Therefore, special characters are encoded 
automatically. This frees applications from the burden to do the 
encoding manually. However, there is less control of the XML generated.

Currently, XMLConfiguration does not supported the generation of CDATA 
sections. You may want to add a feature request in our bug tracking 
system [1].

Oliver

[1] 
http://commons.apache.org/proper/commons-configuration/issue-tracking.html

>
> Thanks
>
> jeevitesh
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message