commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: commons daemon weird behaviour
Date Tue, 26 Feb 2013 07:58:49 GMT
On 02/25/2013 06:38 PM, Jan Šílený wrote:
> Dear mailing list,
> I have run into a strange behavior while using procrun to wrap my java
> application as a Windows service. This issue is linked to DatagramSocket,
> which is created and bound to local port inside the "service". So, what is
> going on: If I run the application as a service, the DatagramSocket stops
> receiving any datagrams after lets say five minutes of proper work. On the
> other hand, if I run my jar simply as a java application (via java -jar
> xxx.jar) everything works fine whole time without this issue.

First thing I would try is to run the service with the same
user account used when running from console. Running under LOCAL_SERVICE
account might introduce some different network settings.

Regards
-- 
^TM

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message