commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Adams <joe.ad...@vividseats.com>
Subject What version of fileupload should I use?
Date Tue, 19 Feb 2013 15:55:24 GMT
Hi,

I'm trying to include commons-fileupload into my project which uses maven.  I seem to have
a conflict.

I got the following exception:
java.lang.NoSuchMethodError: org.apache.commons.fileupload.servlet.ServletFileUpload.parseRequest(Lorg/apache/commons/fileupload/RequestContext;)Ljava/util/List;

My maven has:

<dependency>
<groupId>commons-validator</groupId>
<artifactId>commons-validator</artifactId>
<version>1.3.1</version>
</dependency>
<dependency>
<groupId>commons-codec</groupId>
<artifactId>commons-codec</artifactId>
<version>1.3</version>
</dependency>
<dependency>
<groupId>commons-fileupload</groupId>
<artifactId>commons-fileupload</artifactId>
<version>1.2.1</version>
</dependency>

Which version of fileupload can I include with those versions of validator and codec?

Thanks,
Joe

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message