commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Drew Leamon <aplea...@gmail.com>
Subject Re: [JCS] Remote Cache Server Help
Date Tue, 27 Nov 2012 15:11:09 GMT
Thomas,
     I think that message is a red herring.  It is a warning, not an error
and then the log says that it is bound.   I think the issue is the name
that is bound.  I tried setting up the RemoteCacheServer on a linux server
instead of running it locally on OS X.  I got the same result.  I get this
message from the server:

Nov 27, 2012 9:18:59 AM
org.apache.jcs.auxiliary.remote.server.RemoteCacheServerFactory
registerServer
INFO: Binding server to localhost:1103 with the name
org.apache.jcs.engine.behavior.ICacheServiceNonLocal

And this message from the client:

2012-11-27 10:03:50,895 [btpool0-1] ERROR (RemoteCacheManager.java:163) -
Problem finding server at
[//eadashbd-wc-2d:1103/org.apache.jcs.auxiliary.remote.behavior.IRemoteCacheService]

java.rmi.NotBoundException:
org.apache.jcs.auxiliary.remote.behavior.IRemoteCacheService

at sun.rmi.registry.RegistryImpl.lookup(RegistryImpl.java:124)

at sun.rmi.registry.RegistryImpl_Skel.dispatch(Unknown Source)

at sun.rmi.server.UnicastServerRef.oldDispatch(UnicastServerRef.java:403)

at sun.rmi.server.UnicastServerRef.dispatch(UnicastServerRef.java:267)

at sun.rmi.transport.Transport$1.run(Transport.java:177)

at java.security.AccessController.doPrivileged(Native Method)

at sun.rmi.transport.Transport.serviceCall(Transport.java:173)


Thanks for your help.

        Drew


On Sun, Nov 18, 2012 at 3:28 PM, Thomas Vandahl <tv@apache.org> wrote:

> On 12.11.12 16:28, Drew Leamon wrote:
> > WARNING: Problem creating registry.  It may already be started. internal
> > error: ObjID already in use
>
> Googling for the error message "ObjID already in use" gives you lots of
> results. Bottom line: The RMI registry has already been created by
> someone else in your JDK. As you cannot create a second one, your access
> attempts to the given port fail.
>
> I'm no expert in RMI, so I can only guess that this might be the case
> here. The error message s the result of a system call, so I'd be looking
> for system specifics to resolve this.
>
> Bye, Thomas.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message