commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Putnam <deput...@cisco.com>
Subject Apache Commons Configuration Dependency Incompatibility
Date Wed, 31 Oct 2012 14:13:55 GMT
Iam trying to use CompositeConfiguration class from Apache Commons and 
I'm getting a NoClassDefFoundError 
<http://docs.oracle.com/javase/7/docs/api/java/lang/NoClassDefFoundError.html> 
for NestableRunTimeException. In my reading on this problem there are a 
number of references to incompatible dependencies on versions of 
commons-lang. Unfortunately they all reference versions older than what 
I have. I am using commons-configuration-1.9.jar and 
commons-lang3-3.1.jar in my build path. What are the correct versions I 
should be using? TIA.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message