commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rajika Kumarasiri <raj...@wso2.com>
Subject [VFS] FTPS problem
Date Fri, 07 Sep 2012 10:01:48 GMT
hello,

I am trying to use the FTPS(SSL over FTP) support in commons-vfs. I tried
to resolve a folder in proftpd ftp server(configured only to accept SSL for
control and data). I have the following simple code.

// start of source

            FTPSTest ftpsTest = new FTPSTest();
            StandardFileSystemManager fsm = ftpsTest.getFileSystemManager();

            FileObject file =
fsm.resolveFile("ftps://ftpuser:user123@localhost/test");

            FileObject[] children = file.getChildren();

// end of source

When I tried this FTPs client it fails with an error on server - SSL/TLS
required but absent on data channel, denying LIST command.

I did some debugging and USER, PASS, PORT command was
invoked successfully and user was able to log in. When tries to resolve the
folder it fails with the above error. As the error says it seems there is
no SSL/TLS connections from the client when trying to list the folder(when
I turn off SSL/TLS for data channel things worked as expected).

I looked at the org.apache.commons.vfs2.provider.ftps.FTPSClientFactory I
didn't see any place where the FTPSClient#setKeyManager/TrustManager is
used(although trust store manager is initiated). I was wondering if anybody
has got to work the FTPS support in commons-vfs. I have the SSL debug log
of the client side as well.

Rajika

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message