commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "P.N." <peter.nabbef...@gmx.de>
Subject Re: [daemon] Problems installing & starting a service with procrun
Date Fri, 20 Apr 2012 13:11:35 GMT
P.N. schrieb:
>
> Hello!
>
> ...
>
> This is my command:
> C:\MyServiceDir>commons-daemon\prunsrv.exe //IS//ServiceID
> --DisplayName="Name of Service" --Description="Service description"
> --Install="C:\MyServiceDir\commons-daemon\prunsrv.exe"
> --Classpath=C:\MyServiceDir\lib\xalan.jar;C:\MyServiceDir\lib\activation.jar;MyServer.jar
> --DependsOn=RpcSs ++DependsOn=Nla ++DependsOn=BITS
> --Jvm="C:\jdk1.6.0\jre\bin\server\jvm.dll" --JvmMx=512
> --JvmOptions="-Dsome_option=value" --StartPath="C:\MyServiceDir"
> --Startup=auto --StartParams="-para1:val1;-para2:val2"
> ++StartParams=-test:"some path" --ServiceUser=".\MyAdmin"
> --ServicePassword=MyPassword
> --StartMode=jvm --StartClass=my.class.for.Service --StartMethod=start
> --StopMode=jvm --StopClass=my.class.for.Service --StopMethod=stop
> --StdOutput=auto --StdError=auto --LogPath="C:\MyServiceDir\log"
> --LogLevel=Debug --LogJniMessages=1 --Type=interactive --PidFile="pid"
>
> What am I doing wrong?
>

Just noticed, stability problems resulted from networking problems, sorry.

So these problems are left:
1. Console window - why is it there and how to hide it?
2. After adding --ServiceUser and --ServicePassword, the
    description is no more added to the windows service
3. Service login is not registered correctly
    (Without the auth parameters, --Type is ignored,
     with auth parameters login is LOCALSERVICE/interactive)

BTW, running WinXP.

Kind regards
Peter




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message