commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wayne <whwa...@gmail.com>
Subject Re: [Javaflow] Weird ClassCastException and ClassNotFoundExceptions during build
Date Mon, 27 Jun 2011 08:21:34 GMT
I also met the first problem. but  it seems I  can get
the rewritting classes.


>From  Wayne

2011/6/27 Torsten Curdt <tcurdt@vafer.org>:
> Hey Jeff,
>
> the good news - I was able to reproduce it with your code base.
> Both the exceptions during rewrite and the exception during resume.
>
> I haven't looked at the ASM code in a long time. Seems like there is
> something fishy going on. Maybe the exceptions prevent proper
> instrumentation. I would have to dig into that.
>
> There a couple of things you can try.
>
> - Try the ClassLoader based rewriting to see if you still get the exceptions
> - Question is why the classes cannot be found. Check the classpath.
> - Give the old BCEL rewriting a try. Just to compare the results.
>
> Either way - a test case that can reproduce this in the javaflow tests
> would make it much easier for me to help you out.
>
> HTH
>
> cheers,
> Torsten
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
>
>



-- 
..............................................

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message