commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: [configuration] backslash escaping
Date Thu, 09 Jun 2011 19:18:03 GMT
Hi Vladimir,

Am 09.06.2011 11:05, schrieb Vladimir Stevanovic:
> HI,
> I'm using XMLConfiguration with XPathExspressionEngine and I noticed a
> strange bahavior of configuraiton framework
>
>
> XMLConfiguration config = new XMLConfiguration();
> config.setDelimiterParsingDisabled(true);
> config.setExpressionEngine(new XPathExpressionEngine());
> config.setFile(f);
> if (!config.containsKey("paths")) {
>      config.addProperty(" paths", "");
> }
> if (!config.containsKey("paths/path")) {
>      config.addProperty("paths path", "c:\\some\\path");
> }else {
>      config.setProperty("paths/path", "c:\\some\\other\\path");
> }
> config.save();
>
>
> Afrer running the code above for the first time, created xml file has
> to following line:
> <path>c:\some\path</path>
>
> But afrer running again the line looks like this:
>
> <path>c:\\some\\other\\path</path>
>
> It seems that setProperty is performing some kind of escaping. What's
> the reason for that?
>
there is already a similar bug report in [1]. For this issue a fix has 
been applied in subversion, but there has not been a new release since then.

Would it be possible for you to test with the current snapshot version 
(by checking out the sources and building the jar yourself)?

Thanks
Oliver

[1] https://issues.apache.org/jira/browse/CONFIGURATION-428

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message