commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siegfried Goeschl <sgoes...@gmx.at>
Subject Re: [exec] DefaultExecutor stalling.
Date Fri, 08 Apr 2011 08:33:11 GMT
Hi John

sorry for the delay - I missed the email somehow.

But I'm a bit confused - what you say is that your code blocks on the 
constructor of DefaultExecutor? If this is the case can you provide a 
thread dump to see exactly where it hangs?

Cheers,

Siegfried Goeschl

On 01.04.11 13:13, John Reilly wrote:
> Hi,
>
> I have a patch that needs to run commands on a windows 2003 machine
> from inside a jar file. I'm using commons-exec to run these commands.
> There is an existing servlet on the machine that continuously runs
> commands using ProcessBuilder (Im in the process of changing this to
> commons-exec).
> When the patch runs it gets blocked at the follwing line
> DefaultExecutor executor = new DefaultExecutor();
> When I restart the servlet the patch runs fine to completion.
>
> So the servlet code is blocking the patch.
> Is there anyway I can detect what is blocking from within the patch code.
>
> John
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message