commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Beryle Simmons <Beryle.Simm...@RaymondJames.com>
Subject [daemon] JSVC error Cannot find daemon loader org/apache/commons/daemon/support/DaemonLoader
Date Mon, 07 Mar 2011 20:31:32 GMT
I'm having a problem with JSVC in solaris 10.  We are using it to run tomcat 5.5 and successfully
compiled and ran JSVC version 1.0.1 running tomcat 5.5.29.  due to security bugs in tomcat,
we need to upgrade to tomcat  5.5.33.  I downloaded and copied the tomcat tar.gz file over
to the solaris server, gunzipped and un tarred it.  I compiled JSVC from the source code provided
in the tomcat bin folder (commons-daemon-native.tar.gz).  This was version 1.0.5.  The ./configure
and make ran fine, but I get the below error when trying to run it with the startup script
or from the command line with:

./jsvc    -debug   -cp /opt/tomcat5/bin/bootstrap.jar     org.apache.catalina.startup.Bootstrap


Cannot find daemon loader org/apache/commons/daemon/support/DaemonLoader
java_init failed
Service exit with a return value of 1

I changed permissions to all tomcat files to 777 and changed owner and group to root for all
files, still get same error.  I've researched this on google, but including the commons-daemon.jar
file in the classpath and other fixes don't work.  If I place the 1.0.1 version with the 1.0.1
commons-daemon.jar file in the tomcat 5.5.33 bin directory, it will run fine.   Any help would
be appreciated.

Uname output of server

SunOS 5.10 Generic_141444-09 sun4u sparc SUNW,Sun-Fire-V245

Thanks

Beryle Simmons


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message