commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Littlejohn <>
Subject Re: [jci] Can someone please make a 1.1 release?
Date Sun, 20 Feb 2011 18:24:19 GMT
I did notice that the trunk build currently requires jdk 1.5. Using
jdk 6 the javac compiler implementation doesn't work and some tests
fail (I believe this is down to JCI-43). I note that the reason I can
compile trunk using jdk 1.5 is that the JSR-199 compiler is currently
not include as a module in the parent pom (it's commented out)

Maybe it's best to leave JSR-199 support aside for now? It's clear
that it's going to require some thought on how to maintain Java 1.5
compatibility whilst delivering a JSR-199 based compiler

Given that a JSR-199 compiler was pegged for v1.1, maybe a build of
the current trunk would be better tagged as v1.0.1?

On 20 February 2011 18:11, Christian Grobmeier <> wrote:
>> I am with you guys ...but bumping to 1.5 doesn't buy us much.
>> Only bumping to 1.6 would make things much easier.
> Just to make sure I understood right... jci depended on 1.4, but then
> we started to implement jsr199 which is currently unfinished. Even
> when unfinished we now need j6 b/c of the interfaces used.
> If so, there are these options:
> 1) deliver unfinished jsr199 (would would this mean exactly)?
> 2) remove jsr199 and move it to a branch (have there been many changes
> except jsr199 after the last release?)
> 3) complete jsr199 (how difficult is this?)
> Thanks :-)
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message