commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: [daemon] JRuby can't find rubygems when running from Commons Daemon Jsvc
Date Thu, 13 Jan 2011 17:22:34 GMT
On 01/13/2011 03:13 PM, Michael Glorioso wrote:
> I'm running a JRuby application on a small Linux server. I'm attempting to
> make the application run as a daemon using Commons Daemon Jsvc. After
> implementing the daemon for JRuby as described
> here<http://groups.google.com/group/jruby-users/browse_thread/thread/7e8efe102e2e8aa6>by
> Nick Griffiths, my application fails to start reporting that the
> required

This link doesn't help a bit.

>
> Why would running as a daemon cause rubygems to not be found? How can I fix
> it?
> What other information is needed to help to determine the cause?
>

If it starts from the command line then it should via
jsvc as well. However in jsvc two users are involved;
root and actual user. This means that they both
must have the same environment vars your app depends on.


Nevertheless, without actual log it's hard to tell
what is going on and where the point of failure might be.
You will need to provide more info.

First thing to check is
./jsvc -version -debug ...

Just to see if the required params are set correctly.
What does this produce on your app?


Regards
-- 
^TM

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message