commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Wilk <chris.m.w...@gmail.com>
Subject [daemon] fails start with Java debugging enabled
Date Tue, 21 Dec 2010 09:17:11 GMT
Hello,

I have a problem with Commons Daemon 1.0.4 and JDK 6u21 / 6u23 (both
32-bit and 64-bit). I have observed it both on Microsoft Windows 7 and
Windows Server 2008 R2. I did not exist with Commons Daemon 1.0.2 on
Windows Server 2008 R2.

I cannot use Java Debug Wire Protocol (JDWP) for the purpose of remote
service debugging.

As soon as I am starting newly installed service in service log I have
the following entry:

[2010-12-21 10:08:37] [debug] ( prunsrv.c:528 ) Installing service...
[2010-12-21 10:08:37] [info]  (          :0   ) Service
DVJBSJobServiceJBS6DBG name XXX_JBSJobServiceJBS6DBG
[2010-12-21 10:08:37] [debug] ( prunsrv.c:580 ) Setting service
description XXX_JBSJobServiceJBS6DBG
[2010-12-21 10:08:37] [debug] ( prunsrv.c:585 ) Setting service user
XXX\admingepard
[2010-12-21 10:08:37] [debug] ( prunsrv.c:590 ) Setting service
password Gepardadmin1
[2010-12-21 10:08:37] [info]  (          :0   ) Service
'DVJBSJobServiceJBS6DBG' installed
[2010-12-21 10:08:37] [info]  (          :0   ) Commons Daemon procrun finished
[2010-12-21 10:08:40] [debug] ( prunsrv.c:1493) Commons Daemon procrun
log initialized
[2010-12-21 10:08:40] [info]  (          :0   ) Commons Daemon procrun
(1.0.4.0 64-bit) started
[2010-12-21 10:08:40] [info]  (          :0   ) Running
'DVJBSJobServiceJBS6DBG' Service...
[2010-12-21 10:08:40] [debug] ( prunsrv.c:1241) Inside ServiceMain...
[2010-12-21 10:08:40] [info]  (          :0   ) Starting service...
[2010-12-21 10:08:40] [debug] ( javajni.c:191 ) loading jvm
'c:/Program Files/Java/jdk1.6.0_23/jre/bin/server/jvm.dll'
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[0]
-Djob_service.name=DVJBSJobServiceJBS6DBG
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[1]
-Djob_service.display_name=XXX_JBSJobServiceJBS6DBG
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[2]
-Djob_service.logging.directory=d:/Logs/JBSJobServiceJBS6DBG
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[3]
-Djava.security.manager=default
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[4]
-Djava.security.policy=./server/etc/java.policy
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[5]
-Dconfig.sys=./server/etc/system.conf
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[6]
-Dnet.jini.discovery.debug=1
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[7]
-Djava.rmi.server.hostname=10.48.7.55
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[8]
-Djava.rmi.server.logCalls=true
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[9]
-Dlog4j.configuration=file:///d:/XXX/JBSJobServiceJBS6DBG/log4j.properties
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[10] -Xdebug
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[11]
-agentpath:c:/Program
Files/Java/jdk1.6.0_23/jre/bin/jdwp.dll=transport=dt_socket,address=8084,server=y,suspend=y
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[12]
-Duser.language=en
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[13] -Duser.country=US
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[14]
-Duser.timezone=CET
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[15]
-Dfile.encoding=cp1252
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[16]
-Djava.class.path=d:/XXX\JBSJobServiceJBS6DBG\common\root_class_loader\lib\RootClassLoaderBundle.jar;d:/XXX\JBSJobServiceJBS6DBG\server\lib\JobServiceBundle.jar;d:/XXX\JBSJobServiceJBS6DBG\jobs\_default\lib\JobBundle.jar
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[17] -Xms128m
[2010-12-21 10:08:40] [debug] ( javajni.c:643 ) Jvm Option[18] -Xmx512m
[2010-12-21 10:08:41] [debug] ( prunsrv.c:1054) Java started
appl/dhs/common/runner/ServicePrunRunner
[2010-12-21 10:08:41] [info]  (          :0   ) Service started in 1032 ms.
[2010-12-21 10:08:41] [debug] ( prunsrv.c:1364) Waiting for worker to finish...
[2010-12-21 10:08:41] [debug] ( prunsrv.c:1369) Worker finished.
[2010-12-21 10:08:41] [debug] ( prunsrv.c:1392) Waiting for all threads to exit
[2010-12-21 10:08:41] [debug] ( prunsrv.c:1396) JVM destroyed.
[2010-12-21 10:08:41] [info]  (          :0   ) Run service finished.
[2010-12-21 10:08:41] [info]  (          :0   ) Commons Daemon procrun finished

In service specific logs I have no errors/warnings.

Could you give me some hints why JDWP stopped working with new Commons
Daemon release? I cannot go back to previous (1.0.2) release because
it does not work on Windows 7.


Thanks for any hints or help.

Best regards,
Chris M. Wilk

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message