commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "pieter.breed@gmail.com" <pieter.br...@gmail.com>
Subject Re: [daemon] Cannot find daemon loader
Date Fri, 19 Nov 2010 08:55:19 GMT
This is really weird; I figured out the issue.

The jsvc app choked on the name of the jar file.

I put the date the jar file is created between parens and on my dev machine
I tried to start the file directly and it failed. On the production machine
I have a symbolic link with a plain name pointing to the original file, and
it works.

When I renamed the local file and gave it a simple name it worked fine on
the dev machine too. Maybe this should be put in documentation or some kind
of warning that explains the issue should be given as output?

Anyway, thanks all!

On Thu, Nov 18, 2010 at 18:11, Mladen Turk <mturk@apache.org> wrote:

> On 11/18/2010 02:44 PM, pieter.breed@gmail.com wrote:
>
>> I browsed the fat jar and it contains this:
>>
>> - /org/apache/commons/daemon
>> - /org/apache/commons/daemon/support/
>>
>> The DaemonLoader.class is in the support package.
>>
>> The other thing (not sure if this is relevant) is that I don't have a
>> class
>> that implements the Daemon interface. My class just has methods for init,
>> start, stop and destroy.
>>
>
> You said it works on one box and doesn't on another.
> If that's a case, I doubt it runs by pure luck on the
> first box, so I'd check that other box, cause you must
> have something different.
>
>
> Regards
>
> --
> ^TM
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
>
>


-- 
Give a man fire, he will be warm for a night ; set a man on fire and he will
be warm for the rest of his life.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message