commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mvangeert...@comcast.net
Subject Re: [Lang] 2.5 version osgi settings
Date Mon, 01 Nov 2010 19:56:14 GMT


Oops, that was version 2.3.0 not version 2.5.  I'll try to bring in a newer version. 



v/r, 



Mike Van 


----- Original Message ----- 
From: "Niall Pemberton" <niall.pemberton@gmail.com> 
To: "Commons Users List" <user@commons.apache.org> 
Sent: Monday, November 1, 2010 3:41:33 PM 
Subject: Re: [Lang] 2.5 version osgi settings 

On Mon, Nov 1, 2010 at 7:32 PM,  <mvangeertruy@comcast.net> wrote: 
> 
> All, 
> 
> After attempting to deploy the 2.5 version of org.apache.commons.lang into OSGi, I noticed
the Bundle-ExecutionEnvironment property is set to "JRE 1.1".  Any chance a new bundle can
be created, omitting this property?  The problem is that most OSGi containers currently operate
in a JRE 1.5+ environment, making this bundle not useful.  Omitting the tag entirely will
allow it to be used in any Java execution environment. 
> 

I just checked the MANIFEST.MF file in the commons-lang-2.5.jar and 
there is no  Bundle-ExecutionEnvironment property in it. Are you sure 
you're using the jar we distribute and not one repackaged by someone 
else? 

You can download it here: 

http://commons.apache.org/lang/download_lang.cgi 

Niall 

> 
> 
> v/r, 
> 
> 
> 
> Mike Van 

--------------------------------------------------------------------- 
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org 
For additional commands, e-mail: user-help@commons.apache.org 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message