commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: [daemon] Cannot find daemon loader
Date Thu, 18 Nov 2010 13:38:58 GMT
On 11/18/2010 12:09 PM, pieter.breed@gmail.com wrote:
> I have an 'uber' jar which contains the jars for all dependencies. On my
> server the following command works fine:
>
> sudo jsvc -home /usr/lib/jvm/java-6-openjdk -cp
> /avalanche/avalanche-1.0-SNAPSHOT-\(2010-11-18_12\:33\:43\)-jar-with-dependencies.jar
> -nodetach -debug -verbose -pidfile /var/run/avalanche.pid avalanche.service
>
> But the same command on my dev box does not work. It fails with the
> following messages:
>
> ...
> [Loaded java.io.IOException from shared objects file]
> [Loaded java.util.zip.ZipException from
> /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar]
> [Loaded java.security.PrivilegedActionException from shared objects file]
> [Loaded java.io.FileNotFoundException from shared objects file]
> Cannot find daemon loader org/apache/commons/daemon/support/DaemonLoader
> java_init failed
> Service exit with a return value of 1
>
> I have the /avalanche folder to be:
>
> sudo chmod a+r /avalanche/
>
> but it doesn't change anything.
>
> Does anybody know how to fix this kind of problem?
>

Seems like your fat .jar doesn't contain commons-daemon.jar
I would double check that.


-- 
^TM

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message