commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From trags <Thomas.Rog...@oce.com>
Subject Re: [daemon] Cannot instantiate class: com.sun.jndi.fscontext.RefFSContextFactory
Date Thu, 23 Sep 2010 13:54:14 GMT

Thanks ^TM,
I tried changing the user to my username (Thomas), but no change.  I also
examined the permissions for C:\tmp.  Now all users have full control of
this directory (and descendants).

Your comment caused me to re-examine my diagnostics, however.  I noticed two
things about my path.
1.)  My Java JDK isn't in the path (nor is the JRE in the path).  This is
due to having defined %JAVA_PATH% only for my username, as well as modified
the %PATH% to include %JAVA_PATH%\bin only for my username.  I corrected
these oversights, but they might not be necessary, due to my having
installed the JDK/JRE in C:\Program Files\Java.  Windows seems to find
things there OK.  After making these changes, the log shows no changes
(except that the path is longer for my username than for local_system,
appending some GUI application paths).  It looks now like local_system has
the right paths.
2.)  The library path pre-pends C:\Program
Files\Apache-commons;.;C:\Windows\Sun\Java\bin; to the system-defined path. 
I run the install from C:\Program Files\Apache-commons, so I think that's
where that comes from;  '.' gets the --StartPath= directory (verified by
displaying the current directory in the startup log).  The third one is a
complete mystery, since this directory doesn't even exist!

Is there something else I should check?
Thanks in advance.
Thomas
-- 
View this message in context: http://apache-commons.680414.n4.nabble.com/daemon-Cannot-instantiate-class-com-sun-jndi-fscontext-RefFSContextFactory-tp2550531p2552082.html
Sent from the Commons - User mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message