commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: [daemon]UnsatisfiedLinkError: net exception thown through JSVC but not when natively called
Date Mon, 26 Jul 2010 13:38:21 GMT
On 07/23/2010 12:18 AM, Jason.C.Burns@wellsfargo.com wrote:
> Hopefully the mailing list can help where I have failed after pulling my
> hair out for three days.  Any advice will be greatly appreciated.
>
> I have an AIX 5.2 machine with daemons 1.0.2 and IBM's latest JRE 6
> installed:
>
> bash-3.1# ./jre/bin/java -version
> java version "1.6.0"
> Java(TM) SE Runtime Environment (build pap3260sr8-20100409_01(SR8))
> IBM J9 VM (build 2.4, JRE 1.6.0 IBM J9 2.4 AIX ppc-32
> jvmap3260sr8-20100401_55940 (JIT enabled, AOT enabled)
> J9VM - 20100401_055940
> JIT  - r9_20100401_15339
> GC   - 20100308_AA)
> JCL  - 20100408_01
>
> 1.0.2 is compiled with
>
> ./configure --with-java=$(JAVA_HOME)
> make
>


Sometimes the 'java' binary is a shell script that does things
like setting the LD_LIBRARY_PATH (LIBPATH on AIX IIUC)
and stuff before loading the actual JVM.

Seems like your jvm.so although loaded cannot find other
native libraries (first one was networking stuff, but others
will fail as well later on).

I suppose you would need to add the
<client home>/jre/lib/ppc/j9vm to the LIBPATH
(and probably some more)
before starting jsvc

Regards
-- 
^TM

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message