commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Pagendam-Turner <g...@liftyourgame.com>
Subject Re: [EMAIL] Problem resolving pom to the jar
Date Thu, 13 May 2010 23:19:03 GMT
That solved the problem. Thank you.



On 13/05/2010 3:53 PM, maven apache wrote:
> 2010/5/13 Greg Pagendam-Turner<greg@liftyourgame.com>
>
>    
>> Guys,
>>
>> I'm trying to find out why maven is not downloading the jar file for
>> commons-email
>>
>> In my pom.xml I have
>>
>> <repository>
>> <id>org.apache.commons</id>
>> <url>http://repo1.maven.org/maven2</url>
>> </repository>
>> and
>> <dependency>
>> <groupId>org.apache.commons</groupId>
>> <artifactId>commons-email</artifactId>
>> <version>1.2</version>
>> <type>pom</type>
>> </dependency>
>>
>>      
>
> Remove the type tag:
>
> ----------
> <dependency>
> <groupId>org.apache.commons</groupId>
> <artifactId>commons-email</artifactId>
> <version>1.2</version>
> </dependency>
>
> -----------
>
>    
>> But only the pom and sha1 files are downloaded.
>>
>> I get commons-email-1.2.pom and commons-email-1.2.pom.sha1
>>
>> I'd appreciate any clues on why the commons-email-1.2.jar is not downloaded
>> when I run a mvn package.
>>
>> Regards,
>>
>> Greg.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
>> For additional commands, e-mail: user-help@commons.apache.org
>>
>>
>>      
>    


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message