commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siegfried Goeschl <siegfried.goes...@it20one.at>
Subject Re: [LANG] Having problems with trunk
Date Mon, 19 Apr 2010 19:32:12 GMT
Hi Adrian,

are you interested in coverage or the M2 reports?

If it is coverage only

+) look at Emma - there is a Eclipse integration and M2 plugin
+) IntelliJ has coverage measurement out-of-the box

Cheers,

Siegfried Goeschl

On 15.04.10 20:09, Adrian Crum wrote:
> Thanks Gary! That solved the out of memory error while running mvn site.
>
> The rest of the problems are still there. :-(
>
> -Adrian
>
> --- On Thu, 4/15/10, Gary Gregory<GGregory@seagullsoftware.com>  wrote:
>
>> From: Gary Gregory<GGregory@seagullsoftware.com>
>> Subject: RE: [LANG] Having problems with trunk
>> To: "Commons Users List"<user@commons.apache.org>
>> Date: Thursday, April 15, 2010, 10:55 AM
>> You need to give your JVM more
>> memory. The settings for each JVM vendor is different. For
>> example, for Sun's JVM on Windows I use:
>>
>> MAVEN_OPTS=-Xmx512M -XX:MaxPermSize=128M
>>
>> Check your JVM documentation and experiment with different
>> settings to get your specific set up to work.
>>
>> Gary Gregory
>> Senior Software Engineer
>> Seagull Software
>> email: ggregory@seagullsoftware.com
>> email: ggregory@apache.org
>> www.seagullsoftware.com
>>
>>
>>
>>> -----Original Message-----
>>> From: Adrian Crum [mailto:adrian.crum@yahoo.com]
>>> Sent: Thursday, April 15, 2010 10:17
>>> To: user@commons.apache.org
>>> Subject: [LANG] Having problems with trunk
>>>
>>> I'm having problems working with the lang trunk. I use
>> mvn package to create
>>> the package, and I use mvn site to generate the
>> cobertura reports - which is
>>> what I'm focusing on right now.
>>>
>>> When I tried to run mvn site, the process aborted with
>> a Java out of memory
>>> error (heap space). I commented out all but the
>> cobertura reports in the
>>> reporting section of the pom.xml file and that got it
>> to work.
>>>
>>> The cobertura report task keeps aborting with parse
>> errors. It appears that it
>>> is choking on certain annotations.
>>>
>>> Then I noticed the cobertura report was cumulative -
>> each test run would add
>>> to the coverage. So, I tried to run mvn clean to clear
>> the report between each
>>> test run. That didn't work - the coverage still
>> included test runs before
>>> clean.
>>>
>>> I tried to delete the contents of the target folder
>> manually, but I got an
>>> error message saying that the cobertura folder was
>> being used by another user
>>> or process. I'm the only user and I couldn't find any
>> processes that were
>>> using the folder. After restarting my computer I was
>> able to delete the
>>> folder.
>>>
>>> I don't know what I'm doing wrong. I seem to be having
>> more problems than one
>>> would expect. Any help would be greatly appreciated!
>>>
>>> -Adrian
>>>
>>>
>>>
>>>
>>>
>>>
>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: user-help@commons.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
>> For additional commands, e-mail: user-help@commons.apache.org
>>
>>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message