commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ludwig Magnusson" <lud...@itcatapult.com>
Subject Problems with old and new group id
Date Thu, 15 Apr 2010 14:14:01 GMT
Hi!

I have a dependency in my project that in turn depends on velocity 1.5. More
precisely velocity.velocity (maven 1 layout).

However, my project also _directly_ depends on velocity 1.6.3 or,
org.apache.velocity.velocity (maven 2 laoyt).

Maven doesn't understand that these are different versions of the same
artifact. Is there a way to solve this, because now two velocity packages
are added to my classpath. It seems like this would be a very common problem
with some kind of solution but I can't find information about it.

/Ludwig


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message