commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ludwig Magnusson" <lud...@itcatapult.com>
Subject [EMAIL] Problem with mimemessage
Date Fri, 18 Dec 2009 09:31:46 GMT
Hello!

I want my webapp to send emails to its users.

I'm using turbine, which has VelocityEmail, that uses commons email, which
in turn uses javamail.

I realize that this may be a javamail problem but since the Email class in
commons-email always uses javamail I am asking here to see if anyone have
had the same problem. This list is much more active than javamails own.

 

The problem is that when I compile my app, everything works, but when I run
my webapp I get this error:

 

java.lang.UnsupportedOperationException: Method not yet implemented

                             at
javax.mail.internet.MimeMessage.<init>(MimeMessage.java:89)

                             at
org.apache.commons.mail.Email.buildMimeMessage(Email.java:1011)

                             at
org.apache.commons.mail.Email.send(Email.java:1162)

                             at
org.apache.turbine.util.velocity.VelocityEmail.send(VelocityEmail.java:265)

 

If I goto line 89 in MimeMessage, it consists of javadoc text so obviously
something is wrong.

 

I have tried commons email 1.0, 1.1 and 1.2 all with javamail 1.4.1 and
1.4.3 but I always get this error.

I also worte a small program that uses the exact same code to send the email
and I run it via eclipse. There it works. This suggests that the file I have
in WEB-INF/lib is wrong but it is the same one I have linked as a referenced
library in eclipse.

 

I googled a bit and found other people having the same problem. The solution
there was to make sure that the file in the lib directory was the correct
one, but as I said, I have already checked this.

Does anyone recognize this error?

/Ludwig


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message