commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Carman <ja...@carmanconsulting.com>
Subject Re: Does commons-configuration v1.6 work with JREv1.5? [Commons]
Date Thu, 13 Aug 2009 01:06:53 GMT
It's not compiled with target=1.6.  If you look at the manifest, it
uses the same target as commons-parent-11, 1.3:

X-Compile-Source-JDK: 1.3
X-Compile-Target-JDK: 1.3

It was compiled with a 1.4 Sun JDK:

Created-By: 1.4.2_18 (Sun Microsystems Inc.)
Build-Jdk: 1.4.2_18

So, it should be 1.5 compatible.  What is the exact error you're
getting?  It sounds like you've got a classpath issue.  Are you using
Maven?

On Wed, Aug 12, 2009 at 8:48 PM, Andrew Hughes<ahhughes@gmail.com> wrote:
> Hi, simple question I know... but, I'm lost!!!
> My JavaFX project won't recognize *org.apache.commons.configuration.**.
> JavaFX v1.2's SDK seems to have inherent problems with Java6, because the
> SDK is released with rt15.jar (Java 1.5 runtime)!
> If the answer is yes because configuration 1.6 has a compiled target=1.6 (or
> uses 1.6 classes) then what are my alternatives?
>
> Thanks for reading (and hopefully replying).
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message