commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <ralph.go...@dslextreme.com>
Subject Re: [VFS] Minimum Java version
Date Wed, 19 Aug 2009 14:40:02 GMT

On Aug 19, 2009, at 7:18 AM, Ralph Goers wrote:

> Currently the minimum Java version for VFS 2.0 is 1.4.  VFS 2.0 has  
> not been released and the developers are considering making the  
> minimum version JDK 5. We are interested in getting feedback from  
> the community however before this change is made.  So please respond  
> with your thoughts on this.
>
> Ralph

To answer my own question, Commons Configuration 1.7-SNAPSHOT is using  
Commons VFS 2.0-SNAPSHOT as an optional dependency. Configuration has  
a minimum JDK of 1.3. Although it is an optional runtime dependency,  
some of the public classes are needed at compile time. This has not  
been a problem so far and would be OK provided this continued to work  
after the change. I don't believe it would be a problem to add the  
requirement for JDK 5 to the use of this feature in Commons  
Configuration.

Ralph

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message