commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Emmanuel Bourg <ebo...@apache.org>
Subject Re: Using apache.commons.cli with Java 1.4.2
Date Wed, 10 Jun 2009 16:19:05 GMT
esharris a écrit :
> I'm having difficulty using apache.commons.cli with Java 1.4.2. I used
> Eclipse to develop a simple program that uses apache.commons.cli. The
> program works within the Eclipse IDE. However, when I export the program as
> a Jar file and try to run the Jar from the command line (DOS or Unix). I get
> a NoClassDefFoundErrorerror wrt the CommandLineParser. (In another program
> that uses apache.commons.cli, running the jar file triggers  the
> NoClassDefFoundErrorwrt HelpFormatter. So, I think java punts on the first
> class it sees containing a problem.) 
> 
> I also extracted the apache.commons.cli source and built a Jar from it.
> Strangely, I couldn't compile my program using my cli jar, instead on the
> standard jar. When I extract classes from my cli jar, I noticed some of the
> classes in apache.commons.cli are absent. I don't see anything peculiar in
> the source. 
> 

I don't know how your application is packaged, but did you simply try to 
  put the commons-cli.jar file downloaded from 
http://commons.apache.org/cli in your classpath ?

Emmanuel Bourg


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message