commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Zender00 <danielpenn...@gmx.net>
Subject Net.NNTP: Different behavior using different newsserver
Date Wed, 11 Mar 2009 12:43:37 GMT

Hi,

I got some troubles when I am using the org.apache.commons.net.nntp package
with different (binary-)newsserver.

On my first testserver all methods worked fine
(Connecting/Authentication/Load groups/Load header of a group).

But when I tried to use a different server (same kind of access) I get a
completely different behavior.
Connect and authentication works as the same but I does not receive any
newsgroup. (Method NNTPClient.listNewsgroups() )

On another server I get once again another behavior: This server does send a
lot of group information but I cannot receive any header from a newsgroup:
NNTPClient.retrieveArticleInfo() returns always only an "-1".

When I use GrabIT to scan these different server there are no problems, so I
guess there is something wrong in my nntp package.
Are there any known bugs within this package who can explain this?

Kind regards,
D. Penning
-- 
View this message in context: http://www.nabble.com/Net.NNTP%3A-Different-behavior-using-different-newsserver-tp22454348p22454348.html
Sent from the Commons - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message