commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Nascimento <>
Subject Re: [BeanUtils] Possible to hook in a different getter/setter naming convention?
Date Wed, 21 Jan 2009 20:29:29 GMT
On Fri, Jan 2, 2009 at 8:13 PM, kennardconsulting
<> wrote:
> I was wondering if it was possible to retain this goodness whilst changing
> to a different getter/setter naming convention? Instead of 'getFoo()',
> 'setFoo(x)', I'd like to use 'foo()' and 'foo_$eq(x)' which is the native
> Scala naming convention.

Why not annotating your Scala classes with @scala.reflect.BeanInfo so
a proper BeanInfo gets generated?

Michael Nascimento Santos

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message