commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kennardconsulting <>
Subject [BeanUtils] Possible to hook in a different getter/setter naming convention?
Date Fri, 02 Jan 2009 23:13:36 GMT

Dear All,

I am enjoying using Commons BeanUtils with all its converters and
'' path notation goodness.

I was wondering if it was possible to retain this goodness whilst changing
to a different getter/setter naming convention? Instead of 'getFoo()',
'setFoo(x)', I'd like to use 'foo()' and 'foo_$eq(x)' which is the native
Scala naming convention.

Is there some method/interface to override to make this change without
impacting everything else?


View this message in context:
Sent from the Commons - User mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message