commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Carman" <ja...@carmanconsulting.com>
Subject Re: Commons NET
Date Mon, 01 Dec 2008 02:22:58 GMT
You can always build a version of any of the Apache projects for your own
usage (that's what's so great about the Apache license :).  I'm not very
familiar with the NET code, but if anything within the source code requires
JDK5+, then the entire build will probably have to be run with a JDK5+
compiler.  We might be able to back-port the FTPS support pieces to a 1.x
branch and do another 1.x release (perhaps 1.5.1?), though.  Rory?

On Sun, Nov 30, 2008 at 7:14 PM, Robert Levasseur <bobl@cvlis.com> wrote:

> Commons NET
>
>
>
> The Apache Commons website indicates that the 2.0 branch of Commons Net
> will
> only run on JDK 5.0 or higher.
>
>
>
> Would it be possible for the FTPS components of 2.0 Commons NET to be built
> using Java JDK 1.4.1 ?
>
>
>
> If not and since I only need the FTPS components, is there any reason I
> cannot rebuild these components using 1.4.2 ?
>
>
>
> Thanks.
>
>
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message