commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brosnan, Michael" <michael.bros...@fmr.com>
Subject RE: Commons-beanutils
Date Thu, 02 Oct 2008 13:29:52 GMT
Thanks for the reply

I see that the maven pom file has this set to 25m

              <forkMode>pertest</forkMode>^M
              <!-- limit memory size see BEANUTILS-291 -->^M
              <argLine>-Xmx25M</argLine>^M
              <includes>^M

I tried to do the same with ant using this parameter in ANT_OPTS, but I
still have the same problem.

Is ANT_OPTS the correct way to set this value?

Regards

Mike. 

-----Original Message-----
From: Simon Kitching [mailto:skitching@apache.org] 
Sent: 02 October 2008 12:04
To: Commons Users List
Subject: Re: Commons-beanutils

It might be worth trying to run the tests using an explicit
  -Xmx
setting, eg "-Xmx256m"

This test is checking for memory leaks by allocating some objects that 
should be garbage-collected then forcing garbage-collection. But 
unfortunately there is no java api to force garbage collection. So the 
test simply allocates more and more memory until the garbage-collector 
*has* to run. However if the JVM has a *lot* of memory available to it, 
then filling it up might take a very long time. Perhaps on this machine 
maven forks a jvm instance with a reasonable max-memory setting while 
ant does not?

Regards,
Simon

Brosnan, Michael schrieb:
> I just ran those tests using maven and it worked ok.
>
> Has anyone else ran the tests on commons-beanutils using ant?
>
> Thanks
>
> Mike Brosnan
>
>   
>> _____________________________________________ 
>> From: 	Brosnan, Michael  
>> Sent:	02 October 2008 10:46
>> To:	'Commons Users List'
>> Subject:	Commons-beanutils
>>
>>
>>
>> I'm running the unit tests of commons-beanutils 1.80 and it hangs at 
>>
>>     [junit] Tests run: 10, Failures: 0, Errors: 0, Time elapsed: 0.247
sec
>>     [junit] Running
>> org.apache.commons.beanutils.memoryleaktests.MemoryLeakTestCase
>>
>> It's using 1 GB of memory on a solaris server and when I contol-c the
>> build to stop it, the process doesn't get killed.
>>
>> I'm using JDK 1.5 and ANT 1.7
>>
>>
>> Regards
>>
>>
>> Mike Brosnan
>>
>>
>>     
>
>   


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message