commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton" <niall.pember...@gmail.com>
Subject Re: JDK 1.4 EOL date is October
Date Wed, 02 Jul 2008 13:58:27 GMT
On Wed, Jul 2, 2008 at 10:16 AM, Brosnan, Michael
<michael.brosnan@fmr.com> wrote:
>
> The date for JDK 1.4 bing EOL is October 2008, see
> http://java.sun.com/j2se/1.4.2/
>
> Are there plans in place to update the commons apache components to build
> with JDK 1.5 instead?

Its being done on a component-bycomponent basis. The following list
may not be complete, but this is the state-of-play that I know of:

1) Collections - has had a JDK 1.5 branch for quite some time, not
very active atm
http://svn.apache.org/repos/asf/commons/proper/collections/branches/collections_jdk5_branch/

2) Configuration - Version 2.0 branch requires JDK 1.5:
http://svn.apache.org/repos/asf/commons/proper/configuration/branches/configuration2_experimental/

3) IO - last release (1.4) was JDK 1.4 compatible, but the current
trunk (and the next release, probably 2.0) now requires JDK 1.5

4) Lang - discussed recently on the dev list:
http://markmail.org/message/k36vrkgupiewg3qx

5) Math - Version 2.0 branch requires JDK 1.5:
http://svn.apache.org/repos/asf/commons/proper/math/branches/MATH_2_0/

6) Net - Version 2.0 branch requires JDK 1.5:
http://svn.apache.org/repos/asf/commons/proper/net/branches/NET_2_0/

7) SCXML - J6 branch requires JDK 1.6
http://svn.apache.org/repos/asf/commons/proper/scxml/branches/J6/

Niall

> Regards
>
> Mike Brosnan
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message