commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Goers <Ralph.Go...@dslextreme.com>
Subject Re: Strange performance issues seen with Log.isDebugEnabled()
Date Thu, 26 Jun 2008 15:33:08 GMT


Jean-Philippe Daigle wrote:
> Hi, I'm seeing some very strange performance issues around the use of
> commons logging, and I'm pretty much out of ideas at this point. (Long)
> explanation follows...
>
> <snip>
>   

I suggest getting a copy of YourKit and profiling the application. 
Unfortunately, with the behavior you are seeing this might slow the 
application just enough to cause the problem to go away.  However, from 
your description of the problem it sounds like you have some sort of 
contention going on that is avoiding simply by making the processing 
take a bit more time. If you take out the debugging code and stress it 
hopefully YourKit will show you where the code contention actually is.

A brute force technique I've used in the past (which is fairly tedious) 
is just to take a few thread dumps and then look for threads that are in 
the same place across the dumps or within the same dump. In a system 
without bottlenecks you wouldn't expect to see very many threads at the 
same place.

Ralph

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message