commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "simon.kitching@chello.at" <simon.kitch...@chello.at>
Subject Re: [digester] xml attribute values containing "]" character get scrambled
Date Fri, 16 May 2008 08:44:18 GMT
Ken.Tanaka@noaa.gov schrieb:
>> I'm using digester 1.8, with jdk1.5.0_11 on Red Hat Enterprise 
>> Linux 
>> Client release 5.1.
>>
>>     
> OK, I've tried running the same jar file on my home system and it works
> fine there. The same executable jar on MacOS 10.4.11, java version
> "1.5.0_13" gives correct output--I didn't change anything, just
> downloaded the jar and ran it. I previously had used "maven
> assembly:assembly", so I believe that means all the dependent jar files
> are included (digester 1.8, etc.), except for system libraries, right?
> Does this mean it's more difficult to debug? ;-)
>
> For now I'm just hard-coding the strings in my processing class. I'm
> avoiding adding rules to load these as XML configuration sub-elements,
> because I'm using a pre-existing framework where I can't add the
> RuleSets to do this unless I duplicate that portion of the code; however
> attributes are handled (usually) without changing the framework code by
> just providing the getters and setters in my bean class.
>   

Can you post your ConfigData class?

You could also try enabling debug logging for category
    org.apache.commons.digester
which will give a lot of info about which methods are called when.

Regards, Simon


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message