commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Problem when using ant task SCP
Date Sun, 27 Apr 2008 12:19:26 GMT
This is really an question for the Ant user mailing list.

Try posting the question there.


2008/4/27 Daphna Deutsch <Daphna.Deutsch@opentv.co.il>:
> Hello,
>
>  I'm trying to use the ant task SCP to copy a file from sftp server.
>
>
>
>  I manage to copy a local file to the SFTP server, with no errors. But
>  when I'm trying to copy a file from the SFTP server to a local
>  directory, the file is being copied but I'm getting error message at the
>  end of the task.
>
>
>
>
>
>  This is the task that I wrote:
>
>
>
>  <target name="get_from_sftp">
>
>  <scp file="USER:PAS@IP_ADDRESS:/daphna/res1.xml" todir="D:\result\"
>  trust="yes" sftp="true" />
>
>  </target>
>
>
>
>  And I'm getting the following result:
>
>
>
>  get_from_sftp:
>
>       [scp] Connecting to IP_ADDRESS:22
>
>       [scp] Receiving file: /daphna/res1.xml
>
>       [scp] Receiving: res1.xml : 127
>
>       [scp] File transfer time: 0.02 Average Rate: 8,466.67 B/s
>
>
>
>  BUILD FAILED
>
>  D:\projects\ANT\build.xml:41: com.jcraft.jsch.JSchException: 2: No such
>  file
>
>
>
>
>
>  Thanks for your help,
>
>  Daphna
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message