commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Help with running own service using procrun "FindClass failed"
Date Fri, 29 Feb 2008 16:31:31 GMT

I am trying to start my own service using procrun (aka tomcat5.exe |
tomcat6.exe). I have set up the following commands to do the service

..\bin\tomcat5 //IS//TESTLogger --Startup=auto --LogLevel=debug
dll" --JvmMs=512 --JvmMx=512 --StdError=auto --StdOutput=auto
--LogPath="C:\Test\build\modules\logger\logs" --StartMode=jvm
--StartClass=com.test.logger.LoggerRoot --StartMethod=main
--StartParams=../config --StopMode=jvm
--StopClass=com.test.logger.LoggerRoot --StopMethod=win_shutdown

set LOGGERHOME=C:\Test\build\modules\logger

..\bin\tomcat5 //US//TESTLogger --Description="Test Logging Service"

I know that the jar file specified (test_logger.jar) has the class file
LoggerRoot and have verified the package name as well (com.test.logger),
and when I run the service, the class path looks correct, but I am
getting a not found sort of error. . . can anyone point me it the
correct direction?

Here are the results from my procrun:

2008-02-29 08:54:49 <>  info
<>  Starting service...
2008-02-29 08:54:49 <>  http://385 javajni.c
<http://385%20%20javajni.c/>  debug <>  Jvm
correct classpath here>....
2008-02-29 08:54:50 <>  http://385 javajni.c
<http://385%20%20javajni.c/>  debug <>  Jvm
Option[1] vfprintf
2008-02-29 08:54:50 <>  http://385 javajni.c
<http://385%20%20javajni.c/>  debug <>  Jvm
Option[2] -Xms512m
2008-02-29 08:54:50 <>  http://385 javajni.c
<http://385%20%20javajni.c/>  debug <>  Jvm
Option[3] -Xmx512m
2008-02-29 08:54:50 <>  http://443 javajni.c
<http://443%20%20javajni.c/>  error <>
FindClass com.test.logger.LoggerRoot failed
2008-02-29 08:54:50 <>  http://997 prunsrv.c
<http://997%20%20prunsrv.c/>  error <>  Failed
loading main com.test.logger.LoggerRoot class
C:\Test\build\modules\logger\lib\logger.jar;. . <snip correct path
here>. . . 

I feel it is a path issue, but I just can not see what I am missing. . .
. . . . . Please help!



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message