commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Gregory <bgreg...@g-webdesign.com>
Subject Upgrade OpenJPA to v1.0.2 in Geronimo 2.0 or 2.1 due to bug
Date Thu, 28 Feb 2008 01:16:20 GMT

I've encountered the INSERT instead of UPDATE bug in OpenJPA 1.0.0 (and
verified that 1.0.1 behaves the same) and would like to force my webapp to
use 1.0.2.

I've tried:

1. placing the openjpa-1.0.2.jar in my WEB-INF/lib directory 
2. installing the jar here:
repository/org/apache/openjpa/openjpa/1.0.2/openjpa-1.0.2.jar
3. including the dependency in my geronimo-web.xml

    <sys:dependencies>
      <sys:dependency>
        <sys:groupId>org.apache.openjpa</sys:groupId>
        <sys:artifactId>openjpa</sys:artifactId>
        <sys:version>1.0.2</sys:version>
        <sys:type>jar</sys:type>
      </sys:dependency>
    </sys:dependencies>

4. Removing the 1.0.0 (or 1.0.1) version from the geronimo repository
5. Renaming the jar to openjpa-1.0.0.jar and stomping on top of the jar at
repository/org/apache/openjpa/openjpa/1.0.0/openjpa-1.0.0.jar


In cases 1-3 the following is still reported:
8  default  INFO   [http-8080-1] openjpa.Runtime - Starting OpenJPA 1.0.0

In case 4, geronimo won't start because of dependencies on 1.0.0 (of course)

In case 5 it worked, but it seems like a horrible hack at best (production
management nightmare)

Anyone have a suggestion?


-- 
View this message in context: http://www.nabble.com/Upgrade-OpenJPA-to-v1.0.2-in-Geronimo-2.0-or-2.1-due-to-bug-tp15727187p15727187.html
Sent from the Commons - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message