commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bond - James D." <>
Subject Re: [Configuration] 1.1 to 1.4 upgrade - commas producing a list?
Date Wed, 30 Jan 2008 00:09:40 GMT

You have to tell the Configuration class what to use as the 'delimiter'.  
With XMLConfiguration, I always have this in the startup of my class (so 
that I have no delimiting):


> In our config files, we have LDAP URLs (among other values) that had  
> commas in them.  "ldap://serverhost/DC=domain,DC=com".  With config  
> 1.1, this worked perfectly well; getString() returned the full value  
> exactly as in the XML file.
> I ran into an issue that made no sense with config 1.4 - I only get up  
> to "DC=domain" - the ",DC=com" disappeared from getString().
> When I did a dump of the config properties, I saw that the URI had  
> gotten converted to a list of 2 strings, and getString() silently only  
> returned the first one (as documented).  I have yet to find any  
> documentation on this change nor on how to avoid it.
> This is not what I want.  I can create a list by creating multiple  
> values each in their own tags just fine without this trying to "help"  
> me. :)  How can I restore the original behaviour and/or "escape" the  
> comma to keep it from generating a list and leave the string intact?
> thanks,
> Joe
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

James Dalrymple
Telesoft Corp.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message