commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Lundberg <denn...@apache.org>
Subject Re: commons-logging jar keeps tomcat process runing
Date Tue, 20 Nov 2007 21:30:30 GMT
simon wrote:
> Yes, the ServletContextListener approach documented there in the wiki is
> certainly worth a try. 
> 
> In the almost-released version of commons-logging, a class is included
> in the jar to implement exactly this:
>   org.apache.commons.logging.impl.ServletContextCleaner.
> 
> I suggest you download the commons-logging 1.1.1 release candidate and
> configure the class as a ServletContextListener for your app and see
> what happens. Whether it resolves the problem or not, it would be
> appreciated if you emailed this list with info about the result.
> 
> See:
> http://people.apache.org/~dennisl/
> 
> Hmm..we should probably have published a 1.1.1-snapshot to the apache
> maven snapshot repo, but looks like this has never been done. Ah well,
> the release is coming very soon...

It's here:

http://people.apache.org/maven-snapshot-repository/commons-logging/commons-logging/1.1.1-SNAPSHOT/

> Regards,
> 
> Simon
> 
> On Tue, 2007-11-20 at 20:00 +0100, Dennis Lundberg wrote:
>> Have a look at the second last entry in the FAQ at
>>    http://wiki.apache.org/commons/Logging/FrequentlyAskedQuestions
>> "A memory leak occurs when undeploying/redeploying a webapp that uses 
>> Commons Logging. How do I fix this?"
>>
>> I don't know it is what you are looking for, but it's worth a try.
>>
>> Vaduvoiu Tiberiu wrote:
>>> Hi, I have a small axis application that queries a web service. The application
need commons-logging jar. Everything works ok but when I try to stop tomcat, the process is
still running. If i delete commons-logging jar then tomcat stops normally. I don't know what
can cause this. I tried using several versions of commons-logging, I tried deleteing commons-logging
jar from web-inf/lib and copying commons-logging-api in tomcat/lib but still same problem.
tomcat process is still running after executing shutdown.sh. I am running tomcat 6.0 on Ubuntu.
Does anyone know what can cause this problem or how can I solve it? 10x a lot in advance
>>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
> 
> 


-- 
Dennis Lundberg

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message