commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell" <flame...@gmail.com>
Subject Re: [Commands.Lang] StringEscapeUtils failed with the nbsp
Date Tue, 25 Sep 2007 06:05:42 GMT
Exactly how are you testing it?

Bear in mind, that a unicode nbsp is not the same as a HTML nbsp, so
it won't necessarily appear properly in a browser (at a guess, it will
if you set the content type to unicode).

Hen

On 9/20/07, maomaode <maomaode@gmail.com> wrote:
> Hi,
>
> Thanks for the reply,
>
> I think my platform is ok, i tried on browser, it works.
> I'm testing on windows vista, with jdk6, lang version is the latest.
>
> I'll test on windows 2000 later, see if I can re-produce.
>
> It works on your platform? Can you help me try on your platform?
>
> Thanks in advance,
> James
>
> > On 9/20/07, James Mao <james.mao@iona.com> wrote:
> >
> >> Hi,
> >>
> >> It seems that StringEscapeUtils.unescapeHtml("&#160;") will get "??",
> >> not a space, is it a known issue?
> >>
> >
> > 160 isn't a space, it's an nbsp which is a different character. I
> > suspect the issue is that your console/font/whatever is not able to
> > display it and so shows a "??".  Sound possible?
> >
> > Hen
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> > For additional commands, e-mail: user-help@commons.apache.org
> >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message