commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: problems with configuration
Date Sun, 05 Aug 2007 19:00:20 GMT
James Mansion wrote:
> Oliver Heger wrote:
>> Try builder.getConfiguration().configurationAt(...) instead of 
>> builder.configurationAt().
>>
>> Only the getConfiguration() method causes the configuration sources to 
>> be loaded. The object returned here contains all the properties.
>>
> Surely getConfiguration returns a Configuration, which doesn't have a 
> configurationAt() member?

Sorry, you are right. You can either use the overloaded 
getConfiguration() method, which takes a boolean argument, and set this 
argument to true. Or you cast the result of getConfiguration(). Both 
methods returns a CombinedConfiguration object, which is derived from 
HierarchicalConfiguration.

Oliver

> 
> I had to cast to HierachicalConfiguration first.  Now I get 'Property 
> verbose cannot be set!' which does at least suggest that the bean
> is being constructed.  I'll debug to find out why.
> 
> Thanks!
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
> For additional commands, e-mail: user-help@commons.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message