commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pkimber <mailing.patrick.kim...@gmail.com>
Subject Re: Commons logging - log4j version 1.1.3 and 1.2.13
Date Fri, 10 Aug 2007 12:12:32 GMT

I think I have solved the problem:

When I build the library for Coldfusion I will use commons logging version
1.0.2.  This version of commons logging is old, but supports log4j version
1.1.3.

When I build the library for the web application, I will use the latest
version of commons logging.

The API for commons logging does not appear to have changed from 1.0.2 to
1.1 so my code will still compile.

Does this sound like a plan?

Thanks

Patrick


pkimber wrote:
> 
> Hi
> We have a simple library module which uses commons logging.
> 
> The library will be deployed to two places:
> 1) In a ColdFusion 6 application.  ColdFusion 6 uses log4j version 1.1.3.
> 2) In a standard web application which uses log4j 1.2.13.
> 
> Commons logging works perfectly with version 1.2.13 of log4j but does not
> seem to recognise log4j version 1.1.3.
> 
> Is this a known issue or is there a workaround?
> 
> Thanks for your help,
> 
> Patrick
> 

-- 
View this message in context: http://www.nabble.com/Commons-logging---log4j-version-1.1.3-and-1.2.13-tf4248065.html#a12090117
Sent from the Commons - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@commons.apache.org
For additional commands, e-mail: user-help@commons.apache.org


Mime
View raw message