commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pablo Fernández <pab...@conicet.gov.ar>
Subject Re: Validator 1.1.3 javascript error
Date Wed, 11 Jul 2007 14:59:39 GMT
Niall:

You are absolutely right!!! I'm using Validator 1.0.2 as shipped with 
Struts 1.1. I changed temporally to Validator 1.1.3 version for testing 
purposes only.
My validator-rules.xml contains the JavaScrpit validation routines as 
you say. The JavaScript Struts is generating is fine for me. Actually I 
extracted the line:
    oRequired = new required();
from that JS when viewing html source code. I get the error when 
debugging the JS code...
I believe there's some kind of type definition missing, but I can´t 
figure out what it is!!!

Pablo.

Niall Pemberton escribió:
> On 7/11/07, Pablo Fernández <pablof@conicet.gov.ar> wrote:
>> Sorry for the lack of information!
>> I'm using Struts 1.1 as controller (JSP 1.2 and Servlet 2.3) on a Tomcat
>> 4.1.24 server.
>
> OK Struts 1.1 shipped with Validator 1.0.2 and whether it works with
> Validator 1.1.3 I have no idea. Also the JavaScript validation
> routines in Struts 1.1 was actually configured in the
> validation-rules.xml  - so it wasn't even a part of Commons Validator
> - so how you upgrade to Validator 1.1.3 (when the JavaScript had moved
> to Validator) I have no idea.  The only thing I can suggest is to look
> at the javascript Struts is generating to call commons validator. Then
> take a look at the JavaScript validations in Struts 1.1
> validator-rules.xml and compare to Commons Validator script for 1.1.3
> and see if you can figure out where its different.
>
> Whether that helps you solve it is another matter. Probably if you
> want to use a later Commons Validator version then the easiest thing
> would be to upgrade to Struts 1.2.x
>
> http://wiki.apache.org/struts/StrutsUpgrade
>
> Niall
>
>> Thanks in advance!
>>
>> Pablo.
>>
>> Niall Pemberton escribió:
>> > On 7/10/07, Pablo Fernández <pablof@conicet.gov.ar> wrote:
>> >> Hi, I'm using Validator 1.1.3 and I can't get client side 
>> validation to
>> >> work.
>> >> I get the 'required is undifined' javascript error on this line:
>> >>
>> >> oRequired = new required();
>> >>
>> >> What should I do? Any ideas please?
>> >> Thanks in advance!
>> >
>> > Can you provide more information about the environment you're using
>> > this in - for example are you using this with Struts (if so what
>> > version)? If not Struts then what (if anything) is rendering the calls
>> > to the required validator?
>> >
>> > Niall
>> >
>> >> Pablo.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message