commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jose Correia" <jose.corr...@traderoot.com>
Subject Jelly question
Date Fri, 22 Jun 2007 10:59:01 GMT
Hi all
 
I'm trying to use jelly inside a maven reactor. When I iterate through a
project.xml I have the following component:
 
<dependency>
      <groupId>tools</groupId>
      <artifactId>artifact</artifactId>
      <version>SNAPSHOT</version>
      <properties>
        <classloader>root</classloader>
        <artifact.origin>traderoot</artifact.origin>
      </properties>
    </dependency>
    <dependency>
      <groupId>jaxb</groupId>
      <artifactId>jaxb-api</artifactId>
      <version>1.5</version>
      <properties>
        <classloader>root</classloader>
      </properties>
   </dependency>
 
When I go through the project.xml Iam trying to identify the
"dependency" elements which have not got this subElement :
"artifact.origin" but jelly does not seem to respond to this:
 
<j:forEach var="dep" items="${multipoms.dependencies}">
     <j:choose trim="true">
       <j:when test="${(dep.properties != null) and (not
empty(dep.properties))}">
        <j:forEach var="prop" items="${dep.properties}">
          <j:set var="propArtifact" value="${prop.artifact.origin}D"/>
          <echo>testing2 ${propArtifact}</echo> 
 
     ......
 
When i do that echo, even for the top element above (the one with group
id "tools" and which has a artifact.origin) I get:  testing2 D instead
of testing2 traderootD
How does one deal with a defined element with a "." in it? Does one
escape it as it seems that ${prop.artifact.origin}  doesn't do the
trick....
 
Thanks
Jose
 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message