commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: [Configuration]: Escaping list delimiter
Date Mon, 21 May 2007 20:32:57 GMT
Oliver Heger wrote:
> uma_rk@comcast.net wrote:
>>   > With the escaping of the delimiter character there was a bug in   
>> > Configuration 1.4, which has been fixed recently [1]. Maybe this fix 
>>   > solves your problem?
>>
>> Thanks. I am using 1.4 - is this bugfix available in a new minor release
>> or do I have to build from source to get the fix?
>>
>> If this patch does not fix the problem, I will attach the relevant 
>> excerpts
>> from my implementation.
>>
>> Thanks
>>
>> /U
>>
> 
> There is no new bugfix release since 1.4, but you can get a recent 
> nightly build from [1].
> 
> However I did some testing and found out that this fix will probably not 
> solve your problem: it is specific to XMLConfiguration, but it seems 
> that PropertiesConfiguration does not properly treat the delimiter (and 
> escaping) character, too.
> 
> I will do some more investigation.
> 
> Anyway, thanks for spotting this!
> 
> Oliver
> 
> [1] 
> http://people.apache.org/builds/jakarta-commons/nightly/commons-configuration/ 
> 

fyi, I created a new ticket for this problem:

https://issues.apache.org/jira/browse/CONFIGURATION-269

Oliver

<snip/>

---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message