commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mario Ivankovits <ma...@ops.co.at>
Subject Re: [vfs] vfs-sandbox jar 's vfs-providers.xml gets auto-loaded even when manually configuring
Date Wed, 04 Apr 2007 13:13:16 GMT
Hi Kostis!
>>> Notice that this error happens EVEN WHEN myproviders-only.xml file
>>> DOES NOT SPECIFY the smb provider!
>>>       
>> This is strange, do you have some time to debug into VFS to see whats
>> going on?
>>     
>
>
> I don't find it strange; I believe it is obvious what happens: 
> The "vfs-providers.xml" included into the sandbox jar gets auto-loaded (by 
> the specs).
>   
Hehe ... I didn't find it "strange" that the vfs-providers.xml will be
processed, but that the error message about a already defined smb:://
mapping appears.

> BUGFIX: The solution would be to remove the "vfs-providers.xml" file from the 
> sandbox completely, and put its content into the core jar's 
> core/src/main/java/org/apache/commons/vfs/impl/providers.xml.
>   
Yea,  but this wont happen for the default sandbox library by default.
We can't put it into the core as then if one uses the core without the
sandbox jar will get ClassNotFoundException's  - and it wouldn't make
any sense to add sandbox mappings to the core.

So, what we need to find out is, why VFS complains about a duplicate
smb:// mapping if you do NOT define it - this is something we might be
able to fix. That's what would be nice if you could try to debug.

Ciao,
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: commons-user-help@jakarta.apache.org


Mime
View raw message