commons-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anjana Gopinath <anj...@truenorth1.com>
Subject Re: commons vfs SFTP outofmemory
Date Tue, 07 Nov 2006 21:25:23 GMT
Mario,

Thanks a lof for responding. I had tried setting the -XMx options, it  
worked for some size limit, but for bigger files i got this again.

i beleive vfs didnt hang, it just stopped sftp-ing. i tried with the  
latest stable version of jsch. Shall try again and send you the stack  
trace. i switched to FTP for the time being and that works perfectly  
for large files. (tested with 100MB). But would love to have sftp, so  
will try again today evening and update you soon. Thanks for helping  
me out!


Anjana Gopinath






On Nov 7, 2006, at 4:16 PM, Mario Ivankovits wrote:

> Hi Anjana!
>
>> i am getting an outofmemory exception while trying to do VFS SFTP for
>> a 20 mb file.
> One way to workaround the problem with SFTP and large files is to add
> the -Xmx256M (or appropriate) to your java start command to allow the
> jvm to reserve more memory, but for sure, the OOM exception will come
> back with larger files then.
>
>> i tested this with a timer set to run every minute which invokes vfs
>> ant and this worked for like first 10 mts and after that it stoped
>> copying.
> Hmmmm ... could you please paste a "full stack trace" [1] when vfs  
> stop
> copying, I assume it hangs at all, no?
> That stack trace should give us a clue where it hangs.
> Which version of JSCH do you use? Maybe upgrading to the latest  
> version
> will help.
>
>
> Ciao,
> Mario
>
>
> [1] http://java.sun.com/developer/technicalArticles/Programming/ 
> Stacktrace/
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: commons-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: commons-user-help@jakarta.apache.org
>
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message